注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

还东国的博客

行之苟有恒,久久自芬芳

 
 
 

日志

 
 

Android系列一环境搭建  

2013-03-22 14:21:14|  分类: Android |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

Android系列一环境搭建

历来开发环境的搭建都是繁琐和细枝末节的让人无法忍受的痛苦。特别是在LINUXJAVA平台,在这方面无可否认微软做的比开源的这群家伙强的多,但谁这让这群人开源免费呢,木有办法,还得来。

首先是软件的下载,不得不佩服天朝的管理,据小道消息,做管理这个软件的北邮的某人快挂掉了,正所谓,天作孽;犹可恕,人作孽,不可活。

http://www.cnblogs.com/yaotong/archive/2011/01/25/1943615.html

这里说明一下,正是由于网络管理,所以好多的软件无法下载,所以具体的下载,这里只是提供一个现在可下的。包括后面的JAVA,Eclipse及其它相关的软件,不再提供下载地址,大家可以去网上找,很方便。

首先这里需要说明的是,开发环境有两种,一种是在LINUX下,大家可以使用FEDORA系列或者Ubuntu系列,其它的大家可以参照这两类。

另外一种就是WINdows了。

在网上大多都没有分清这些。一会LINUX下,一会儿WIN下,当然,还有用cygwin的,原来用过这个,后来之所以不用他了,主要原因是一个是不好下载,另外一个有真实的LINUX环境(虚拟机)为什么非要这个。

然后就是安装的步骤,这个基本都差不多:

1.         下载JAVA1.6.0.41),安装,配置环境变量,记得重启使环境变量生效,当然也可以使用SOURCE之类的命令来实现不重启生效。LINUX下的配置文件在/etc/profile,当然如果只是想让本用户使用,可以用别的方法,大家可以去查资料。(PATH和JAVA_HOME一定要在一起,即或同在系统环境变量,或在用户环境变量中,不能一上一下)

2.         下载ANDROID SDK(android-sdk_r21.1-windows ),安装,LINUX下比较简单解压缩,然后运行ANDROID这个执行文件,自动升级,这里有麻烦了,由于GOOGLE与天朝不合作的态度,所以这个升级就得看人品了,反正这次升级没有成功。WIN下就简单了,直接安装。

3.         下载ECLIPSE(eclipse-java-juno-SR1-win32)相应的版本,注意,下载的所有的版本的软件要相互适应,这个可以看文档。WIN下安装,LINUX下解压缩即可使用。

4.         安装ADT,CDT等开发插件,这个可以下载下来,也可以在ECLIPSE中的帮助,安装软件中写入库地址(在官网中的下载项目中有)自动升级。

5.         下载NDK,解压缩即可使用,在LINUX下可以增加环境变量,方法如上面的提到的。

6.         这样,基本一个开发框架就安装好了,这里之所以只写一个流程,没有详细的说明,主要原因是,网上这些东西太多了,可以参考以下几篇BLOG

http://blog.csdn.net/steven_miao/article/details/6107251

http://blog.csdn.net/guanhuhousheng/article/details/7492418

http://blog.csdn.net/lvmengcool1/article/details/7882280

然后大家就可以写一个简单的示例,运行一下了。只要不报错误,说明你的程序成功了。如果报错,基本原因不外乎是环境变量没配置对,软件的版本不对应,最后就是人品差。

主要说开发,从下一篇开始。

其作始也简,其毕将也必巨也。

  评论这张
 
阅读(508)| 评论(0)
推荐 转载

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017